New Microsoft Windows vulnerabilities require patching

August 14, 2019

If you use Microsoft Windows Windows 7 SP1, Windows Server 2008 R2 SP1, Windows Server 2012, Windows 8.1, Windows Server 2012 R2, or all versions of Windows 10, including server versions, read this article here for crucial information about updating due to newly discovered security vulnerabilities.

Running Windows update can seem time consuming and unproductive, but making sure your system is secure will save you a headache down the road and help keep your data safe. 

 

 

Leave a comment

Please note: comments must be approved before they are published.

x